nix-weather/.config/treefmt.nix
Christina Sørensen 747e481bcb
style: nixfmt-rfc-style
Signed-off-by: Christina Sørensen <christina@cafkafk.com>
2024-09-07 11:43:13 +02:00

21 lines
560 B
Nix

# SPDX-FileCopyrightText: 2024 Christina Sørensen
# SPDX-FileContributor: Christina Sørensen
#
# SPDX-License-Identifier: EUPL-1.2
{
projectRootFile = "Cargo.toml";
programs = {
nixfmt-rfc-style.enable = true; # nix
statix.enable = true; # nix static analysis
deadnix.enable = true; # find dead nix code
rustfmt.enable = true; # rust
shellcheck.enable = true; # bash/shell
taplo.enable = false; # toml
yamlfmt.enable = true; # yaml
};
settings = {
formatter = {
shellcheck.excludes = [ ".envrc" ];
};
};
}